Share Poll

Poll link

500 px
350 px
250 px
Preview

widget preview:

Width - px Height - px

Close preview
! You are using a non-supported browser Your browser version is not optimised for Toluna, we recommend that you install the latest version Upgrade
Our Privacy Notice governs your membership of our Influencer Panel, which you can access here. Our website uses cookies. Like in the offline world, cookies make things better. To learn more about the cookies we use, check out our Cookies policy.

banner982

  1 month ago

Anyone else noticed that when you complete a survey the points show as being credited and yet your total does not reflect the points you have just earned ?

Just had yet another one like this and it happens on a very regular basis ! Pointless contacting the powers that be as you simply receive the usual reply that they have been credited.
Reply
Post

J8970483x89

  1 month ago
Only just joined Reply
0 comments

bexbananaboat

  1 month ago
Yes, they do take a few minutes to catch up lately. Reply
0 comments

Chris563

  1 month ago
Yes it can take a while before the points show up Reply
0 comments

Scorpio70

  1 month ago
It's normal. It can take 10 min or so for your total to update. Nothing to worry about. I have it all the time. Reply
1 comments

TolunaTeamEN

  1 month ago
Hi banner982, this could be a slight time delay and is usually nothing to worry about. However, if you'd like to be sure, please don't hesitate to reach out to the help desk team :) Have a great day! Reply
2 comments

gljcleeve

  1 month ago
With so many surveys not paying at all it's just not worth the hassle and disappointment of keeping track, just move on and hope. Reply
1 comments

Mark_W

  1 month ago
It’s just the usual gremlin I think! Reply
1 comments

yvonne7495

  1 month ago
I dont check tbh i think all the time checking and chasing up is better spent doing topics and surveys Reply
1 comments

CathHMN

  1 month ago
Like Minnie, I have noticed a time lag but all points have been added to my total. Reply
1 comments

spartan3002

  1 month ago
That's one of the few things I haven't had Phil ! Reply
2 comments
Copied to clipboard

You’re almost there

In order to create content on the community

Verify your Email / resend
No thanks, I’m just looking

OK
Cancel
We have disabled our Facebook login process. Please enter your Facebook email to receive a password creation link.
Please enter a valid Email
Cancel
We're working on it...
When you upload a picture, our site looks better.
Upload